[JAG Practice Contest for ACM-ICPC Asia Regional 2016 , Japan][AIZU2782]We don't wanna work!
博客迁移

Wine TIM 更新

Zarxdy34 posted @ 2018年3月11日 17:07 in Linux , 74 阅读

       Update2018:由于QQ又更新了一些东西,并且老版也不能用了,wine搞不了,目前用这个https://www.lulinux.com/archives/1319

        由于网上的教程对应的都是较老的版本的QQ/TIM(2017年以及之前的版本),老版本可以非常流畅地使用,但是QQ9.0/TIM2.15后出现了很多新的问题,就在这里记录一下。这里只装tim,QQ的新版本问题好像特别多。

        txplatform禁用,riched20和riched32改为native then builtin,msvcp60~140全部改为native then builtin(老版本是msvcp60,新版本不是,没仔细测过是哪一个,以后再测),系统改成win10,然后直接安装tim,再用winetricks安装这里的文件https://pan.baidu.com/s/1w2JfultvAZjIXEHW7P3jPA(原地址为https://www.ithome.com/html/win10/307236.htm),这样一来基本上就没有问题了。

        然后比较烦人的一个问题是群公告、群文件等全部打不开,用老版本和新版本前后试了一下,新老版本都有这么一句话:

fixme:ras:RasEnumConnectionsW RAS support is not implemented! Configure

        用新版本的QQ测试了一下,打开群公告、群文件等东西时terminal里显示的全部都是这句话。接下来再测试一下老版本QQ有没有这个问题。新老版本都有这个,这个不知道是不是问题。

        安装过程中经常会出现“QQ安全组件异常”而打不开的问题,用wineboot重启一下wine就可以了,wineboot没有反应的话就kill掉wineserver。

        先放着......经过测试,2.0.0版本的tim是能正常用的,之后版本会出现上述bug,2.1.0版本非常非常卡,所以暂时用2.0.0版本的tim,以后再看一下。下载地址:http://mydown.yesky.com/pcsoft/107250956/versions/


登录 *


loading captcha image...
(输入验证码)
or Ctrl+Enter